Back to overview
Degraded
The website is undergoing major fixes
Nov 27 at 07:45pm CET
Affected services
cptl.studio
Resolved
Nov 27 at 08:37pm CET
All website functions are working, we will be working on restoring the look of the website.
Affected services
Created
Nov 27 at 07:45pm CET
We are experiencing problem with out website, it may look strange while we try to fix the issues.
Affected services